TheSSS (The Smallest Server Suite) 26.2

TheSSS (The Smallest Server Suite) is a lightweight server suite distributed as a live CD. It is designed for system administrators who need an extremely tiny and fast set of server software. The supported servers are: DNS, FTP, HTTP, HTTPS, NFS, MySQL, SFTP, SMTP, SSH, and Telnet. A proxy server (Polipo with Tor) is also included. The main security components are the 4MLinux Firewall (based on iptables) and Clam AntiVirus. ISO images are fully compatible with UNetbootin, which can be used to create an easy-to-use TheSSS Live USB.

Tags server 4mlinux
License GNU GPLv3
State production

Recent Releases

26.214 Oct 2018 13:53 minor feature: This is a minor (point) release based on the 4MLinux Server 26.2, meaning that the components of the LAMP server are now: Linux 4.14.74, Apache 2.4.35, MariaDB 10.3.10, and PHP (both 5.6.38 and 7.2.10). You can update your TheSSS by executing the "zk update" command (fully automatic process).
26.116 Sep 2018 10:08 minor feature: This is a minor (point) release based on the 4MLinux Server 26.1, meaning that the components of the LAMP server are now: Linux 4.14.68, Apache 2.4.34, MariaDB 10.3.9, and PHP (both 5.6.37 and 7.2.10). You can update your TheSSS by executing the "zk update" command (fully automatic process).
26.022 Aug 2018 19:15 major feature: This is a major release based on the 4MLinux Server 26.0, meaning that the components of the LAMP server are now: Linux 4.14.64, Apache 2.4.34, MariaDB 10.3.9, and PHP (both 5.6.37 and 7.2.9). You can update your TheSSS by executing the "zk update" command (fully automatic process).
25.215 Jul 2018 13:05 minor feature: This is a minor (point) release based on the 4MLinux Server 25.2, meaning that the components of the LAMP server are now: Linux 4.14.55, Apache 2.4.33, MariaDB 10.3.8, and PHP (both 5.6.36 and 7.2.7). Additionally, Adminer has been updated to its version 4.6.3. You can update your TheSSS by executing the "zk update" command (fully automatic process).
25.117 Jun 2018 19:34 minor feature: This is a minor (point) release based on the 4MLinux Server 25.1, meaning that the components of the LAMP server are now: Linux 4.14.48, Apache 2.4.33, MariaDB 10.3.7, and PHP (both 5.6.36 and 7.2.6). Additionally, Postfix has been updated to its version 3.3.1. You can update your TheSSS by executing the "zk update" command (fully automatic process).
25.012 May 2018 21:52 major feature: This is a major release based on the 4MLinux Server 25.0, meaning that the components of the LAMP server are now: Linux 4.14.39, Apache 2.4.33, MariaDB 10.2.14, and PHP (both 5.6.36 and 7.2.5). You can update your TheSSS by executing the "zk update" command (fully automatic process).
24.214 Apr 2018 15:58 minor feature: This is a minor (point) release based on the 4MLinux Server 24.2, meaning that the components of the LAMP server are now: Linux 4.14.33, Apache 2.4.33, MariaDB 10.2.14, and PHP (both 5.6.35 and 7.2.4). Additionally, BIND has been updated to its version 9.11.3. You can update your TheSSS by executing the "zk update" command (fully automatic process).
24.117 Mar 2018 19:55 minor feature: This is a minor (point) release based on the 4MLinux Server 24.1, meaning that the components of the LAMP server are now: Linux 4.14.25, Apache 2.4.29, MariaDB 10.2.13, and PHP (both 5.6.34 and 7.2.3). Additionally, Postfix has been updated to its version 3.3.0. You can update your TheSSS by executing the "zk update" command (fully automatic process).
24.012 Feb 2018 12:04 major feature: This is a major release based on the 4MLinux Server 24.0, meaning that the components of the LAMP server are now: Linux 4.14.18, Apache 2.4.29, MariaDB 10.2.12, and PHP (both 5.6.33 and 7.2.2). The 4MLinux Server 24.0 introduces three major changes: the LAMP suite has been compiled for 64-bit CPUs, NFS support (client and server) is now available out of the box, the installation CD includes so called Legacy Installer, which makes it possible to install TheSSS on machines having only 256 MB of RAM. You can update your TheSSS by executing the "zk update" command (fully automatic process).
23.314 Jan 2018 20:51 minor feature: This is a minor (point) release based on the 4MLinux Server 23.3, meaning that the components of the LAMP server are now: Linux 4.9.76, Apache 2.4.29, MariaDB 10.2.12, and PHP (both 5.6.33 and 7.2.1). As one can see, this is the first release, which includes the PHP 7.2.x series. You can update your TheSSS by executing the "zk update" command (fully automatic process).
23.217 Dec 2017 13:02 minor feature: This is a minor (point) release based on the 4MLinux Server 23.2, meaning that the components of the LAMP server are now: Linux 4.9.69, Apache 2.4.29, MariaDB 10.2.11, and PHP (both 5.6.32 and 7.0.26). The following server software has also been updated: OpenSSL (1.0.2n) and Stunnel (5.44). You can update your TheSSS by executing the "zk update" command (fully automatic process).
23.122 Nov 2017 16:11 minor feature: This is a minor (point) release based on the 4MLinux Server 23.1, meaning that the components of the LAMP server are now: Linux 4.9.61, Apache 2.4.29, MariaDB 10.2.10, and PHP (both 5.6.32 and 7.0.25). The following server software has also been updated: OpenSSL (1.0.2m), Postfix (3.2.4) and Stunnel (5.43). You can update your TheSSS by executing the "zk update" command (fully automatic process).
23.022 Oct 2017 13:32 major feature: This is a major release based on the 4MLinux Server 23.0, meaning that the components of the LAMP server are now: Linux 4.9.52, Apache 2.4.28, MariaDB 10.2.9, and PHP (5.6.31 and 7.0.24). Webmin has been updated to the version 1.850. Much improved support for SCSI, RAID and LVM devices is now available out of the box. And finally, the biggest change is related to the installation script, which now makes it possible to install TheSSS on ext2, ext3, ext4, reiserfs, jfs, xfs, btrfs, and nilfs2 partitions. You can update your TheSSS by executing the "zk update" command (fully automatic process).
22.316 Sep 2017 19:02 minor feature: This is a minor (point) release based on the 4MLinux Server 22.3, meaning that the components of the LAMP server are now: Linux 4.9.49, Apache 2.4.27, MariaDB 10.2.8, and PHP (5.6.31 and 7.0.23). PHP Command Line Interface (aka PHP CLI) has been added to both the PHP packages. Additionally, the SSHFS support is now available out of the box. You can update your TheSSS by executing the "zk update" command (fully automatic process).
22.220 Aug 2017 09:44 minor feature: This is a minor (point) release based on the 4MLinux Server 22.2, meaning that the components of the LAMP server are now: Linux 4.9.43, Apache 2.4.27, MariaDB 10.2.7, and PHP (both 5.6.31 and 7.0.22). The following server software has also been updated: BIND (9.11.2) and Stunnel (5.42). You can update your TheSSS by executing the "zk update" command (fully automatic process).
22.115 Jul 2017 15:23 minor feature: This is a minor (point) release based on the 4MLinux Server 22.1, meaning that the components of the LAMP server are now: Linux 4.9.33, Apache 2.4.27, MariaDB 10.2.7, and PHP (both 5.6.31 and 7.0.21). The following servers have also been updated: DNS (BIND 9.11p3), SMTP (Postfix 3.2.2) and SSH (OpenSSH 7.5p1). You can update your TheSSS by executing the "zk update" command (fully automatic process).
22.017 Jun 2017 12:55 major feature: This release is based on the 4MLinux Server 22.0, meaning that the components of the LAMP server are now: Linux 4.9.13, Apache 2.4.25, MariaDB 10.2.6, and PHP (both 5.6.30 and 7.0.19). Additionally, DNS (BIND 9.11), FTP (ProFTPD 1.3.6), SMTP (Postfix 3.2.0 with Procmail and Fetchmail) servers are included, too. The 4MLinux server can be manged via its user-friendly WebGUI (LAMP Admin with Webmin 1.840).
7-21.019 Feb 2017 18:16 major feature: TheSSS7 uses PHP7 (7.0.15) while the standard TheSSS includes PHP5 (5.6.30). All other features (Linux 4.4.30, Apache 2.4.25, MariaDB 10.1.21) are the same for both the versions.
21.012 Feb 2017 22:39 major feature: This release is based on the 4MLinux Server 21.0, meaning that the components of the LAMP server are now: Linux 4.4.30, Apache 2.4.25, MariaDB 10.1.21, and PHP 5.6.30. This is the first TheSSS release that includes the lftp utility (v. 4.7.5).
20.026 Oct 2016 13:38 major feature: This release is based on the 4MLinux Server 20.0, meaning that the components of the LAMP server are now: Linux 4.4.17, Apache 2.4.23, MariaDB 10.1.18, and PHP 5.6.27.
19.028 Aug 2016 20:23 major feature: This release is based on the 4MLinux Server 19.0, meaning that the components of the LAMP server are now: Linux 4.4.14, Apache 2.4.23, MariaDB 10.1.16, and PHP 5.6.25.
18.026 Jun 2016 08:54 major feature: This release is based on the 4MLinux Server 18.0, meaning that the components of the LAMP server are now: Linux 4.4.8, Apache 2.4.20, MariaDB 10.1.14, and PHP 5.6.22.
17.025 Apr 2016 20:59 major feature: This release is based on the 4MLinux Server 17.0, meaning that the components of the LAMP server are now: Linux 4.4.1, Apache 2.4.20, MariaDB 10.1.13, and PHP 5.6.20.
16.026 Feb 2016 15:57 major feature: This release is based on the 4MLinux Server 16.0, meaning that the components of the LAMP server are now: Linux 4.1.13, Apache 2.4.18, MariaDB 10.1.11, and PHP 5.6.18.
15.025 Dec 2015 18:37 major feature: TheSSS (The Smallest Server Suite) is a lightweight server suite distributed as a live CD. This release is based on the 4MLinux Server 15.0, meaning that the components of the LAMP server are now: Linux 4.1.10, Apache 2.4.18, MariaDB 10.1.9, and PHP 5.6.16. This is the first release, which includes Postfix to handle emails sent via PHP mail.